Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 88

Thread: KTM 2T troubleshooting

  1. #21
    Join Date
    May 2007
    Location
    Meriden
    Posts
    4,550

    Default

    Kill switch?? One of the guys from the mmc suggested looking at that route.
    LRRS# 772 NETRA#3772
    Boston Tier 1 Racing
    Amsoil/DP Brakes / AXO America/Vortex Racing/ Woodcraft/Armour Bodies/Racer Gloves/Hiflofiltro oil filters

  2. #22
    Join Date
    Sep 2010
    Location
    S.E. CT
    Posts
    2,349

    Default

    Kyle could the low compression be the cylinder walls are washed down with fuel? You've had trouble starting it for a bit now. Just a thought..

  3. #23
    Join Date
    Oct 2006
    Location
    Baltic, CT
    Posts
    3,354

    Default

    Were throttle bodies jammed open when you did the compression test?

    Stupid but any chance plug wires reversed
    USA doom sealed Dec. 2, 1970

  4. #24
    Join Date
    Aug 2008
    Location
    beacon falls
    Posts
    6,211

    Default

    Quote Originally Posted by chrismpero View Post
    Kyle could the low compression be the cylinder walls are washed down with fuel? You've had trouble starting it for a bit now. Just a thought..
    I'm actually not getting much/any fuel into the cylinder. After many kick attempts the plug is dry/ no fuel smell. I have taken the carb apart and cleaned all jets and passages. i honestly think the cylinder isn't creating enough vacuum to pull fuel in.


    Quote Originally Posted by theducman View Post
    Kill switch?? One of the guys from the mmc suggested looking at that route.
    One of the first things i checked track side, and again in my garage. it's functioning as it should and i am getting plenty of spark at the plug

    Quote Originally Posted by richw View Post
    Were throttle bodies jammed open when you did the compression test?

    Stupid but any chance plug wires reversed
    Only 1 plug. Single Cyl 2T. and yes, i had the throttle pinned open while kicking for compression.

  5. #25
    Join Date
    Aug 2009
    Location
    Maine
    Posts
    1,228

    Default

    Solve the mechanical issue first (low compression) and you may find you don't have an electrical issue?
    771 Racing -=- FaceBook
    Backed by Heroic Racing Apparel
    A-ko - 1992 FZR400RR SP / Mistake - 1992 WR250ZD / Facade - 2003 YZF-R6 / 2000 LS650P

  6. #26
    Join Date
    Aug 2008
    Location
    beacon falls
    Posts
    6,211

    Default

    Quote Originally Posted by Kurlon View Post
    Solve the mechanical issue first (low compression) and you may find you don't have an electrical issue?
    i know i don't have electrical issues anymore. I had no spark, now i have great spark, but still no boom. Top end should be here tuesday and i'll be hosting a garage night shortly after that to crank out the work.
    Last edited by ITGbuDeev; 07-27-2018 at 01:31 PM.

  7. #27
    Join Date
    May 2009
    Location
    Pomfret
    Posts
    10,291

    Default

    I'm guessing you already checked reeds?
    -Christian LRRS/CCS #856 ECK RacingGMD Computrack Boston | Pine Motorparts/PBE Specialists | Woodcraft | Street & Competition | OnTrack Media

    2011 Pit Bike Race CHAMPION!

  8. #28
    Join Date
    Aug 2008
    Location
    beacon falls
    Posts
    6,211

    Default

    Quote Originally Posted by csmutty View Post
    I'm guessing you already checked reeds?
    yup. one of the multiple times i took the carb out to check/clean. looked new to me

  9. #29
    Join Date
    Aug 2008
    Location
    beacon falls
    Posts
    6,211

    Default

    changed the name of the thread since this is no longer an electrical issue.

    New pipe and top end kit arrived yesterday. who knows what they are looking at and is free in the next week or so to dive in with me? I'll provide food and beer.
    Last edited by ITGbuDeev; 08-03-2018 at 07:27 AM.

  10. #30
    Join Date
    May 2007
    Location
    Meriden
    Posts
    4,550

    Default

    Quote Originally Posted by ITGbuDeev View Post
    changed the name of the thread since this is no longer an electrical issue.

    New pipe and top end kit arrived yesterday. who knows what they are looking at and is free in the next week or so to dive in with me? I'll provide food and beer.
    I might be able too assist. I can bring an army of two stroke guy's along if the stars align
    LRRS# 772 NETRA#3772
    Boston Tier 1 Racing
    Amsoil/DP Brakes / AXO America/Vortex Racing/ Woodcraft/Armour Bodies/Racer Gloves/Hiflofiltro oil filters

Similar Threads

  1. Replies: 13
    Last Post: 10-10-2011, 06:26 PM
  2. Triumph guys - Detailed technical troubleshooting question
    By DucatiMichael in forum The Garage
    Replies: 30
    Last Post: 08-10-2011, 07:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •